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Overview
There are two parts to ExpressPCB, our CAD software and our board manufacturing service.  Our 

CAD software includes ExpressSCH for drawing schematics and ExpressPCB for designing circuit 

boards.  After you complete your PC board design, we provide a low cost, high quality and fast 

source for having your boards made.  Here is how it works:

1. We recommend that you begin your project by drawing a schematic using ExpressSCH.  

Drawing a schematic is not required, but it will save you time when designing your board 

and reduce the possibility of wiring errors.

2. Next, use the ExpressPCB program to layout your PC board.  If you link your schematic to 

ExpressPCB, the program will guide you through the wiring process by highlighting how 

the components should be connected.

3. When your layout is complete, you can determine the exact cost of having your boards 

made with the Compute Board Cost command.

4. To order the boards, simply enter your name, address and billing information into 

ExpressPCB and press the Send button within the Order Boards Via The Internet dialog 

box.



5. In a few business days (typically 2 or 3) an overnight courier will deliver your PC boards.

Note:  See Board Manufacturing Options to learn about the different PC board 

manufacturing choices we offer.

The Display

Take a few minutes to acquaint yourself with the ExpressPCB main window, shown below.  You 

will notice that there are two toolbars, one along the top and another along the left side.  At the 

bottom of the display is a statusbar.

The Statusbar

The statusbar shown along the bottom has three fields.  The first field shows the XY position of 

the mouse.  The units are in inches.  The coordinate (0,0) represents the upper left corner of 

your board.

In the middle of the statusbar is the Snap list box.  Here the snap-to-grid feature can be turned 

on and its spacing set.  When on, placing items such as components and traces automatically 

align to the snap-grid.

The field on the right displays helpful information when you connect traces to the pins of 

components.  For example, the display might read:  "Connecting to pin 11 of U4" when you 

attach a trace to that pin.



The Side Toolbar

The toolbar along the left side of the main window is used to select between the different editing 

modes, such as place pad, place component and place trace.  Each of these modes can be 

selected either with the mouse or a shortcut key.

Note:  When you click on one of the side toolbar buttons, additional buttons are 

added to the top toolbar that are specific to the function selected.

The buttons along the side toolbar are:

Select, drag or set properties of an 

item in the layout.
Place text in the layout.

Zoom to view a selected area. Place a rectangle.

Place a pad (either a through hole 

or surface mount pad).
Place a circle or an arc.

Place a component.
Place an automatically filled power or 

ground plane.

Place a trace. Insert an edge segment in the board 

perimeter.

Insert a corner into a trace. Display information about a pad.

Disconnect a trace. Highlight net connections.

At the bottom of the side toolbar are 4 additional buttons that toggle on and off features of 

the display:

Toggle display of silkscreen layer. Toggle display of bottom copper layer.

Toggle display of top copper layer. Toggle Snap-to-grid.

The Top Toolbar

The toolbar at the top of the main window has nine buttons that are always shown:

Open a PCB file. Zoom in. Zoom to previous size.

Save the file. Zoom out. Display Options dialog box.

Undo last operation. Zoom to see all. Display the Component 

Manager.

Also displayed on the top toolbar are the following buttons.  Depending on the mode selected 

with the side toolbar, one or more of these may be added: 

Move selected items to 

top layer.
Set rotation up. Highlight first net.

Move selected items to 

bottom layer.
Set rotation left. Highlight previous net.

Select top silkscreen 

layer.
Set rotation down. Highlight next net.



Select top copper layer. Set rotation right. Highlight last net.

Select bottom copper 

layer.

Set text weight to 

normal.
Set text weight to bold.

Units and the Coordinate System

By default, the ExpressPCB program displays coordinates in Inches with the origin (0, 0) located 

at the upper left corner of the board.  Sometimes it can be very useful to move the origin or to 

select metric units.  The most common reason to make these changes is to aid in designing a 

custom PCB footprint.  To accurately set the position of the individual pads of a footprint, it is 

frequently helpful to move the origin to the component's center, or over pin 1.  If the datasheet 

for a component shows the pin spacing in metric units, changing the ExpressPCB program to 

millimeters makes placing the pads very easy. 

To change the display units, select either Inches or Millimeters in the Options dialog box.  Then 

update the Snap-to-grid spacing (also in the Options dialog) with an appropriate value.

The (0, 0) origin can be positioned anywhere on the board.  Feel free to move it as often as you 

like as it only affects the display of coordinates; it does not actually make changes to objects in 

the layout.

To move the origin, from the View menu select the command Set origin with mouse.  Next click 

on your board at the point where you want the origin to be located.  If the Snap-to-grid is on, 

then the origin will be positioned at a grid location.  The origin can be restored to its original 

position using the menu command Reset origin to upper left.

Note:  Internally the ExpressPCB program saves the coordinates of objects in 

inches with a resolution of 0.001".  Values entered in millimeters are converted to 

the nearest thousandth of an inch.  The value entered in the Snap-to-grid field of 

the Options dialog box is a true floating point number and can be set with 6 digits 

to the right of the decimal point. 

The Grid

Displayed in the main window is a grid of small white dots.  This grid is helpful when placing 

components and traces so that they align nicely.  The grid is only a display tool and will not 

appear on your final printed circuit board.

As you zoom out to view a large area of your board, you will notice that the grid is not always 

displayed.

The grid is configurable and can be modified in the Options dialog box.  You can display or hide 

the grid, and also set the spacing between grid lines.  The spacing is typically set to 0.1 inches.

The Snap-to-grid is an invisible grid that is also configured in the Options dialog box.  It is very 

helpful when placing items to ensure that they are automatically aligned.  If the Snap-to-grid 

feature is turned on, pads, components and traces always gravitate to a grid boundary when 

dragged with the mouse.  Typically the Snap-to-grid spacing is set to 0.05 inches (half of the 

Grid spacing).

The Snap-to-grid feature is most easily toggled on or off by pressing the G key or by clicking 

 at the bottom of the side toolbar.

Tip:  Quick changes to the Snap-to-grid spacing can be made from 

the list box on the statusbar.

Traces with Corners



Corners allow traces to bend.  They are displayed as small square 

blocks at the ends of trace segments.  A trace with two corners is 

shown here.  Corners in a trace can be dragged, inserted or deleted to 

change the trace's path.  In your final PC board layout, the corners will 

not be included.

Example PCB Files

When learning to use our software, it is often helpful to first review a few example PCBs.  In the 

directory where ExpressPCB is installed, you will find several example files having a .PCB 

extension.  Load these files into the ExpressPCB program using the Open command from the File 

menu.  Typically they are located in the directory:

C:\Program Files\ExpressPCB

Understanding the Layers of a PCB
ExpressPCB manufactures double-sided boards (with 2 copper layers) and 4 layer boards (with 4 

copper layers).  Double-sided boards work well for most simple applications. They are somewhat 

less expensive and take fewer days to manufacture than four-layer boards. But four-layer boards 

offer advantages. They are better at controlling electrical noise and four-layer boards can be 

smaller with components closely spaced together.  Also these boards are easier to lay out.

Depending on the options you choose, your boards can have as few as two layers, or as many as 

seven.  The layers from top to bottom are:  

1. Silkscreen

2. Top Solder Mask

3. Top Copper

4. Inner Copper Ground Plane

5. Inner Copper Power Plane

6. Bottom Copper

7. Bottom Solder Mask

All boards have a Top copper and Bottom copper layer.  The Top copper layer is on the component 

side of the board and is displayed in red by the ExpressPCB layout program.  The Bottom copper 

layer is on the solder side of the PCB and is shown in green.  

The optional Solder masks layers are green coatings that cover the top and bottom of the board.  

The coating is applied everywhere except over the pads where components are soldered.  These 

masks make soldering easier by helping to prevent solder bridges from forming between adjacent 

pads and traces.

Boards with solder masks also include a Silkscreen layer.  The Silkscreen layer is used to show the 

outlines of components, and text identifying each part.  The outlines and text are printed on the top 

of the board in white ink.

Four-layer boards have two additional copper layers that are not included with Double-sided 

boards.  Sandwiched inside these PCBs are two inner layers, a Ground Plane and a Power Plane.  

Any through-hole pad on a four-layer board can be connected to or isolated from either of these 

planes.  Because the inner layers are completely filled copper planes, they greatly improve the 

noise immunity of your circuit.

Our Standard Service and Standard MiniBoard Service manufacturing options deliver boards without 

a silkscreen or the two solder mask layers.  It is not necessary to consider these layers when 

designing your board.  However, even though the silkscreen layer is not printed on the final PCB, 

we still recommend that you create it to document the placement of each component in your circuit.

Our Production Service, ProtoPro Service, and MiniBoardPro Service manufacturing options include 



the silkscreen layer and the two solder masks layers.  These layers give the board a more 

professional appearance.

Tip:  Use the Options dialog box to turn on or off the display of each layer.  A 
layer must be turned on before you can make additions or changes to it.

The solder mask layers are displayed in reverse.  Solder mask is applied everywhere on the board, 

except where something is drawn on the layer.  The ExpressPCB layout program automatically 

blocks the solder mask from pads and components from our library.  However, if you want to 

expose other copper areas, do so by drawing on the solder mask layers.  For example, if you create 

edge connector fingers using trace segments, you will want to place large rectangles on the solder 

mask layers to prevent the entire edge connector from being covered with mask.

Note:  See Drawing on the Solder Mask Layers to learn more about removing 
areas of solder mask.

Beginning a New Layout
1. Begin a new layout by running ExpressPCB.  You can launch ExpressPCB from your desktop by 

clicking on the  icon.   If you would like to design a four-layer board, select Board 

properties from the Layout menu and check the 4-Layer option.  

2. In the main window is a yellow rectangle that defines the perimeter of the PC board.  You will 

want to change the yellow rectangle to the size of the board that you want to make.  To do 

this, move three of its four corners (the upper left corner is fixed at coordinate (0,0) and 

cannot be moved).

A corner can be moved two ways:  by dragging it with the mouse or by double clicking on it and 

then entering a new coordinate.  If you drag the corners, it is helpful to keep an eye on the 

statusbar to determine the new dimensions of the board.

Additional corners can be inserted into the board perimeter to define more complex board 

shapes.  See Changing the Board Perimeter for more information.  

Note:  Our MiniBoard Service requires that your board be a rectangle, exactly 3.8 

inches wide and 2.5 inches tall.  The New command under the File menu starts 

with an empty board of this size.

3. Now select the Default via.  As you place traces, ExpressPCB may in some cases automatically 

insert a via (a plated-through hole with pads) when a trace changes between the upper and 

lower layers.  These automatically placed vias will always be visible.

Set the size of the Default via from the Layout menu by choosing Board properties.  In the 

Board properties dialog box, select a value from the Default via list box.

For digital and other low power circuits, 0.048" round via is a good choice.  With our four-layer 

manufacturing options, we offer a very small 0.026" via, extremely useful when designing 

dense circuitry.  

Tip:  When placing wide traces, remember to change the automatically inserted 

vias to larger ones by double clicking on them and setting a new size.

4. If you have drawn a schematic of your circuit using ExpressSCH, link the schematic file to your 

circuit board layout using the Link schematic to PCB command found under the File menu.

5. Finally, give your board a name by selecting Save As from the File menu.

Scrolling and Zooming

Scrolling the Main Window



In addition to scrolling using the scrollbars, you can also scroll with the mouse and the arrow 

keys.  While dragging an item such as a pad or a trace with the left button down, moving the 

mouse outside the main window causes it to scroll.  You can also scroll the using the keyboard 

by pressing the Up, Down, Right or Left arrow keys.

Zooming In and Out

There are four buttons along the top toolbar that are used to zoom the main window in and out:

Zoom in.  (+ shortcut key)

Zoom out.  (- shortcut key)

Zoom out to fit the entire layout.  (F shortcut key)

Zoom to the previous display.

You can zoom into a specific region of the layout by choosing  and then dragging the 

mouse.  Simply enclose the area you wish to expand and center.

The easiest way to move around your layout is with the scroll wheel on the mouse.  

Turning the wheel zooms in and out.  Pressing the wheel and dragging the mouse 

pans the view side to side and up and down.

Placing Items in the Layout

Placing Components - Using the Toolbars

There are a couple of ways to place component footprints on your board.  Here is how to insert 

components using the toolbars:

1. From the side toolbar, select  or press the C shortcut key.

2. Select the component type from the drop down list box on the top toolbar as seen here:

There are three categories in the list: 

•  Favorite components:  parts that you have book-marked.

•  Custom components:  parts that you have built.

•  Library components:  parts that are included with the program.

3. Select the component's orientation (rotated up, left, down, or right) by clicking on one of:

  

4. Move the mouse into the main window, press the left mouse button, and drag the 

component to the desired location.

5. While dragging the component, the R shortcut key can be used to rotate the component.  

The + and - keys zoom in and out, and the G key toggles the snap-to-grid on and off.

6. After placing the component, assign it a Part ID (such as R1 or U2).  Do this by selecting 

 then double click on the component to display the Component properties dialog box.

Note:  Your must set the Part ID if you want to link your schematic and PCB 



files.  In order for ExpressPCB to mate a component from your schematic with 

the part in your board layout, the Part IDs must match. 

Often it is easiest to place additional copies of a part using Copy and Paste.

Placing Components - Using the Component Manager

An alternate way to place components 

in your board layout is to use the 

Component Manager.  

The advantages of using the 

Component Manger are that it 

displays a bigger window of part 

names; it also shows the parts in a 

preview window and you can search 

for parts by name.

To place a component:

1. Click the  button located on the top toolbar to display the Component Manager.

2. Select one of these categories:

•  Library components  -  Components that are included with the program

•  Custom components  -  Components that you have drawn

•  Favorite components  -  Components or symbols that you have book-marked

3. From the list box, choose the item to insert.

4. Select the component's orientation (rotated up, left, down, or right) by clicking on one of 

the following buttons:

  

5. Press the Insert component into PCB button and then drag the component to the desired 

location.

6. Assign the component a Part ID (such as R1 or U2).  To do this, select  then double 

click on the component to display its Component properties dialog box.

Note:  Setting the Part ID is required if you choose to link your schematic and 

PCB files.  In order for ExpressPCB to mate a component from your schematic 

with the part in your board layout, the Part IDs must match. 

The Find button in the Components Manager makes it easy to search for a 

part.

Placing Pads

Individual pads are used to build new components.  They also serve an important purpose as 

via, which are used to connect traces between the top and bottom layers.  To insert a pad:

1. From the side toolbar, select  or press the P shortcut key.



2. Select a pad from the drop down list box on the top toolbar:  

The list box shows the pad diameter, pad type and hole size.  

There are several types of pads: round, square, surface mount and via.  Square pads are 

typically used on pin 1 of a component.  Vias are used to pass traces between layers.  

Round and via pads differ only in that ExpressPCB may eliminate a via if all the traces 

connecting to it are on the same layer.

If you can not find a pad the size you need, a custom pad is easily added to the list using 

the Pad Manager.  You can also use the Pad Manager to add the pads you most frequently 

use to your favorites list.  See:  Making Custom Pads & The Pad Manager.

Note:  The hole size in a pad represents the finished hole diameter after 

plating.  Remember it is better to pick a hole that is too big, rather than one 

that is too small.

3. With the pad type selected, move the mouse into the main window, press the left mouse 

button down and drag it to the desired location.

4. While you drag the pad, the + and - keys zoom in and out, and the G key toggles the 

snap-to-grid on and off.

5. A pad or via can be connected to a Filled Plane or an inner layer power plane (of a 4 layer 

board) by right clicking on the pad.

Placing Traces

These are the steps to add traces to your layout.  If you have drawn a schematic for your circuit, 

be sure to read the section Linking the Schematic and PCB before you begin.

1. From the side toolbar, select  or press the T shortcut key.

2. Select the trace width from the drop down list box on the top toolbar:  

A width of 0.010" is a good default for digital and analog signals.  For Vcc and Gnd power 

lines, use traces 0.05" or wider.

3. Select the layer by clicking on  or by pressing the L shortcut key.

4. Move the mouse to the trace's first endpoint and click left.  Drag the trace to the second 

endpoint, then click left again.  Continue placing trace segments (the L key can be used to 

change layers) until you have reached the final endpoint.

Tip:  Keep an eye on the statusbar when connecting traces to components.  It 

will display the pin and part number (as set in that component's properties 

dialog box) to which the trace is connected.

5. As you drag the trace, the L key changes layers, the Del key deletes the previous 

segment, the + and - keys zoom in and out, the G key toggles the snap-to-grid on and off, 

the Spacebar sets the trace, and the Esc key cancels it.

6. To complete the operation, either press the Spacebar or click right.

Inserting Corners in Traces

1. Corners (displayed as small blocks) can be inserted in an existing trace to change its route.

To insert a corner, select  or press the I shortcut key.



2. Select the layer on which the corner will be placed by clicking .

3. Click on the trace where you want to add the new corner.

4. Drag the corner to the desired location.

Placing Text

Text can be placed on the silkscreen layer or on either of the copper layers.  Text written on the 

copper layers will conduct electricity, so be careful not to place it over traces or components.  

Also remember that the silkscreen layer is not printed on boards when you choose our Standard 

Service or Standard MiniBoard Service manufacturing options.

1. To place text, select  from the side toolbar or press the A shortcut key.

2. From the top toolbar, choose the layer, orientation and the text weight (normal or bold).  

3. Select the height of the text from the drop down list box.

4. Enter your text in the text box along the right hand side of the toolbar as 

shown in this example:

5. Move the mouse into the main window, press the left mouse button and drag the text to 

the desired location.

Note:  Text on the bottom layer is displayed as the mirror image.  This causes 

the text to read correctly when your PC board is made.

6. As you drag the text, the L key toggles the layer, the R key rotates the text, the + and - 

keys zoom in and out, and the G key switches the snap-to-grid on and off.

Placing Rectangles

Rectangles are typically used make high current electrical busses, heat sink areas, or to piece 

together ground planes.

To place a rectangle, select  and then pick the layer by clicking on .  Next, drag 

the mouse to place the rectangle and set its size.

Important Note:  Rectangles by default are covered with a green solder mask 

(when you choose our Production, ProtoPro or MiniBoardPro  manufacturing 

options).  If a rectangle is added to a circuit that serves as an electrical contact, the 

rectangle must be un-masked by drawing on the solder mask layer.  See: Drawing 

on the Solder Mask Layers

Placing Power and Ground Planes

Filled Planes are used to add ground or power planes to a circuit.  They 

can be placed on either the top or bottom copper layers.  They are 

typically drawn as a large area that surrounds components and serve to 

help control electrical noise.  The outer perimeter of a Filled Plane can 

have the shape of any polygon and the interior is automatically insulated 

from traces and pads.

Note:  The Filled Plane feature is not supported in Windows 95, 98 or ME.

To place a Filled Plane, select  and then click on  to choose the layer.  On the top 

toolbar, select the Draw filled plane option.  Next using the mouse, draw a polygon to define the 

perimeter of the plane.  Do this by clicking the left mouse button at each corner of the polygon, 



then clicking right after you have placed the last corner.  You will now notice that the polygon is 

filled, creating the plane, but clearance is automatically added around traces and pads, isolating 

them from the plane.

Once a Filled Plane is added to your circuit, its shape can be changed.  

First select the plane with the mouse.  The size of the plane can then be 

adjusted by dragging the square corners.  To eliminate sides of the 

polygon, click on a square corner, then press the Del key.  Additional 

sides can be inserted by dragging the circles.

Pads inside a plane can be connected to it 

using either a Solid or Thermal pad shape.

Connect a pad to a plane by right clicking on 

the pad.  Then in the popup menu, select 

either Top layer pad shape or Bottom layer 

pad shape.  Lastly pick the pad type: 

Thermal pad to filled plane or Solid pad to 

filled plane.

Tip:  Typically thermal pads are used when 

a pad is connected to a plane and a 

component lead will be soldered to the pad. 

Thermal pads improve the solderability of 

the pad, reducing the chance of a "cold 

solder joint".

There may be areas inside a plane that you do not want filled.  To draw 

a Keep out area, select , then from the top toolbar choose the Draw 

keep out area in filled plane option, along with the layer.  Next use the 

mouse to draw the polygon that defines the perimeter of the keep out 

area.  

Note:  The outlines of keep out areas are displayed with a 

dotted line, but the dotted lines will not be included on the PCBs.

Clearance around traces and pads are automatically added inside Filled Planes.  The amount of 

clearance can be changed.  The default values for the trace clearance and the pad clearance are 

set in the Board Properties dialog box.  Larger values may be required when working with high 

voltage signals.

The amount of clearance for an individual trace can be set by first double clicking on it.  Then in 

the dialog box, choose the Custom clearance option and enter the desired gap width.

A trace can be connected to a plane by removing the clearance gap.  This is done by placing the 

trace in the circuit, then double clicking on it and selecting the 0 Clearance option.

Important:  After creating a plane, you will want to inspect it for these types of problems:

1. Carefully look for areas of the plane that are too thin to be 

manufactured.  In this example, the plane includes a thin strip 

that connects the right and left thermal pads.  If any part of a 

plane is smaller than 0.007"  the PCBs we manufacture may not 

include that feature.  It is up to you to ensure that your planes do 

not have any copper areas with dimensions smaller than 0.007" 

as these areas may be disappear when the boards are made, 

even though you can see them on the screen.



Tip: To quickly judge if a feature in a plane is too small, place 

a 0.007" trace nearby and visually compare their widths.

2. Check your plane for "copper islands" that are not electrically 

connected to the rest of the plane.  This example shows pin 2 

connected to the plane, but this section of the plane is isolated 

from the surrounding plane.

In this case, you will want to connect islands to the greater plane 

using pads and traces.

3. Sometimes  tiny copper islands and thin strips are created within 

your filled plane. These must be manually eliminated from your 

design.  It is possible for these tiny copper fragments (smaller 

than 0.007") to shift during the manufacturing process, resulting 

in a short circuit elsewhere on your board.

Thin strips between traces are easily eliminated by increasing the 

Custom clearance of the neighboring traces.  Tiny islands can be 

removed by drawing Keep out areas.  Both of these techniques 

are described above.

After adding a Filled Plane, it is easiest to work on other parts of the layout if the plane is hidden 

or locked.  In the Options dialog, check Hide filled plane to make planes invisible, check Lock 

filled plane to prevent planes from being selected or moved.  If planes are hidden, they will still 

be included when the boards are manufactured.

Designing a 4-Layer PCB
ExpressPCB manufactures double-sided boards (with two copper layers) and four-layer boards (with 

four copper layers).  Four-layer boards offer advantages over double-sided.  They are better at 

controlling electrical noise, can be smaller with closely spaced components and are easier to layout.

Setting the Number of Copper Layers

Begin a four-layer design by checking the 4-Layer option in the Board properties dialog box 

found under the Layout menu. This adds two inner layers to your board, a Power plane and a 

Ground plane. Because these inner layers are completely filled copper planes, they greatly 

improve the noise immunity of your circuit. 

Note:  When the 4 Layer option is selected, it also enables a smaller via than is 

available with our double-sided service. This via has a pad diameter of 0.026". When 

designing a very compact board, we recommend using this via size. You can set it as 

the default via in the Board Properties dialog box.

Connecting to the Inner Layers



Any through-hole pad in a layout can 

be connected to either the Power or 

Ground internal planes. To do so, right 

click on the pad to connect.  In the 

popup menu, select one of the Power 

inner layer pad options to connect the 

pad to the Power plane, or choose one 

of the Ground inner layer pad options 

to connect it to the Ground plane.

Connections to the internal Power 

plane are displayed with a + over the 

pad. Ground plane connections are 

marked with a - symbol.

To look at the actual inner layer planes, open the Options 

dialog box and check either View Power inner layer or View 

Ground inner layer. Here we show what the Power layer 

looks like for the example above. 

This example shows pins 2, 4, and 14 are connected to the 

Power plane. All of the other pads are isolated from the 

Power plane.

You will notice that pins 2, and 14 are connected to the 

plane with Thermal pads, while pin 4 is connected with a 

Solid pad.

Tip:  Typically thermal pads are used when a pad is 

connected to a plane and a component lead will be 

soldered to the pad. Thermal pads improve the solderability 

of the pad, reducing the chance of a "cold solder joint".

Split power planes and keep out areas can be placed on the inner layers.  Do so by 

first displaying the layer using the Options dialog box and checking either View 

Power inner layer or View Ground inner layer.

To place a Split Plane, click  then select the Draw split plane option on the top 

toolbar.  Next use the mouse to draw the polygon that defines the perimeter of the 

isolated plane.

Keep out areas (a region of the inner layer that you do not want any copper) are 

drawn by selecting  along with Draw keepout area on the top toolbar.  Then 

draw the perimeter of the copper free region.

Note:  It is not possible to draw traces on the inner layers.

Editing the Layout

Setting Properties of an Item



Each item in your layout has specific properties.  For example, the properties of a pad include 

the pad type and the position of the pad.  To view or change the properties of an item, select 

 from the side toolbar and then double click on the item.

 Moving Items in the Layout

There are three ways most items can be moved.  Typically, you move items by selecting and 

dragging them.  They can also be moved with the arrow keys by selecting them and then 

pressing Ctrl-right, Ctrl-left, Ctrl-up or Ctrl-down.  Alternately, an item can be moved by 

changing the coordinates set in its properties dialog box.

Moving Traces

Traces themselves cannot be moved.  The position of a trace is determined by the straight line 

between the two endpoints of what it is connected to.  Therefore, to move a trace, you either 

need to connect it to something different, or move what it is connected to.

Often the solution to moving a trace is to drag its corners.  Several corners can be selected at 

once and then dragged together.  In some cases, you will want to insert additional corners to 

form new bends.

To disconnect a trace and reconnect it elsewhere, select  from the side toolbar.  Next, click 

on the trace near the point that you want to disconnect and then drag the trace to a new pin.

Deleting Items From the Layout

Deleting items from your layout is as easy as selecting them and pressing the Del key.

Tip:  Keep in mind that almost every operation can be undone with the Undo 

command in the Edit menu.

Copying Items

ExpressPCB uses standard Edit commands for Copy, Cut and Paste.  To copy, first select the 

item or several items of interest.  Next, choose Copy from the Edit menu.  Then choose Paste.  

The new copy will appear selected in the middle of the window.

Copying all or Part of a PCB to Another File

It is not possible to copy sections of a board layout between two ExpressPCB programs running 

at the same time.  However, you can easily copy all or part of your PCB to another file as follows:

1. Using the mouse, select the region of the layout that you would like to copy.

2. From the Edit menu, choose Copy.

3. From the File menu, open the PCB file into which you want to insert this region.

4. Select the Paste command from the Edit menu to copy the circuit into this new file.

Changing the Layer of Items

It is easy to move traces, rectangles and text between layers.  First click on  in the side 

toolbar.  With the mouse, select the items of interest.  From the top toolbar, click on 



 to move the selection to the top layer; click on  to move it to the bottom.

 Rotating Items 90 Degrees

A section of a layout can be easily rotated in 90-degree increments.  Do this by first selecting 

the components, pads and traces of interest.  Then from the Edit menu choose Rotate Selection 

90°.  Repeat the command to rotate 180 or 270 degrees.

Right Click Menu

Many editing functions can be executed from Right Click Popup menus.  Do so by clicking on an 

item in your layout with the Right mouse button.  A popup menu will appear with several 

commands listed such as Copy, Paste, Rotate, Flip, and Set Properties. 

Changing the Board's Perimeter

The size and shape of your board is defined by the edge markers shown in yellow.

For rectangular boards, setting the board size is as easy as setting the position of the corners.  

The upper left corner is fixed at location (0,0) and cannot be moved.  The width of the board is 

set by moving the two corners along the right side, and the height is set by moving the corners 

along the bottom.

A corner can be moved in one of two ways, you can drag it with the mouse, or double-click on it 

and then enter new coordinates in the properties dialog box.  If you drag the corners, it is 

helpful to keep an eye on the statusbar to determine the new dimensions. 

To define more complex board shapes, insert additional edges into the board perimeter by 

selecting  from the side toolbar.  Next, click on existing edges where you would like to add 

the new corners.  Drag the corners to define the board size and shape.

Tip:  To make a round board, it is helpful to first place a circle on the silkscreen 

layer.  Draw it using the Circle/Arc tool found on the side toolbar.  The yellow 

perimeter-marker in the upper left corner of the layout cannot be moved, so move 

the circle such that this corner is on the edge of the circle.  Now add additional 

corners to the perimeter, equally spacing them around the silkscreen circle.  Zoom 

in to help align each corner perfectly.

Note:  Our boards are routed to the shape defined by the board perimeter set in 

your layout.  Slots in the perimeter must be at least 0.125" wide.  Narrower slots 

will not be milled correctly.  MiniBoards must be in the shape of a rectangle, exactly 

3.8 inches wide and 2.5 inches tall.

Drawing on the Solder Mask Layers

Solder mask layers are a green coating that cover the top and bottom of the board (when you 

choose our Production, ProtoPro or MiniBoardPro manufacturing options).  This coating is applied 

everywhere on the board except over pads.  A solder mask makes assembling boards easier by 

helping to prevent solder bridges from forming between adjacent pads and traces.

The ExpressPCB layout program automatically blocks the solder mask from our library pads and 

components.  If you want to expose other areas, do so by drawing lines, arcs and rectangles on 

the solder mask layers.  To draw on one of these layers, it must first be displayed by checking 

View top solder mask layer or View bottom solder mask layer in the Options dialog box.  The 

solder mask layers are displayed in reverse (solder mask is applied everywhere on the board, 

except where something is drawn).



For example, if trace segments or rectangles are used as the fingers of an edge connector, they 

must be un-masked to expose them.  In this case you will want to place a large rectangle over 

the entire edge connector on the top and bottom solder mask layers to prevent the fingers from 

being covered.

Other Commands

Linking the Schematic and PCB

The process of wiring your components together with traces can be simplified if you link the 

schematic and PCB files.  Typically the ExpressSCH schematic drawing program is used to create 

the schematic.

FYI:  If you are using a different schematic program, continue reading these 

instructions for working with ExpressSCH files, then see the note below on 

importing netlists.

Embedded in ExpressSCH schematic files are wiring lists (called NetLists) that describe which 

pins should be connected together.  By loading this information, the ExpressPCB program can 

guide you when you place traces by showing which pins need to be wired together.

Before linking your schematic, you will want to check it for errors.  Run the command Check 

schematic for netlist errors from the File menu of ExpressSCH.  If any errors are reported, 

correct them and then save the schematic by choosing Save from the same menu.

 For more information, see:  ExpressSCH: Checking the Schematic for Errors

Next, for every part referenced in your schematic, you need to insert the component footprint 

for that part in your PCB design.  Also, the Part ID values for each footprint must be set.  To 

learn how to insert the footprints and set the IDs, see:  Placing Components

Note:  The Part IDs are used by the ExpressPCB program to match a schematic 

component with its PCB footprints when highlighting a net.  (i.e. a Part ID of R12 in 

the schematic is matched with a PCB footprint that also has the Part ID set to R12).  

Now you are ready to link your schematic and circuit board.  From the File menu of the 

ExpressPCB program, select the command Link schematic to PCB.  Here, select the filename of 

your schematic.

Once linked, ExpressPCB can show you which pins 

should be connected together by highlighting them in 

blue.

To highlight a "Net", select  from the side toolbar, 

then click on one of the pads of a component.  This 

highlights the other pads that should be wired to the 

pad you've selected.  If the schematic has nothing 

connected to that pin, then no pads are highlighted.

You can step through all of the "Nets", from first to last, to visually inspect 

your PCB for missing connections.  To do this select  and then use 

these buttons on the top toolbar to navigate through all of the nets:

Tip:  The ExpressPCB program reloads the linked schematic file every time the .PCB 

file is opened.  If you run ExpressSCH and ExpressPCB at the same time, you can 

update the link by first saving the schematic within ExpressSCH.  Then select Refresh 

link to schematic from the File menu in ExpressPCB.

Note:  Netlists created using schematic programs other than ExpressSCH (such as 



OrCAD) can be imported if converted to the proper format.  Four formats are 

supported:  PadsPCB, Pads2000, Multiwire and ExpressPCB.  Netlists in these 

formats are imported using the Import netlist text file command from the File 

menu. 

Making Custom Components

ExpressPCB includes many components that you can use to create your PCB.  However if you 

need a footprint not found in our library, you can easily build your own.  Here is an example of 

how to create a through-hole component.  The same procedure is used to design surface-mount 

parts.

1. Begin by adding the pads.  To do this, select  and choose a pad 

type from the list box on the top toolbar.  If you cannot find a pad 

the size you need, a custom pad can be created.  See:  Making 

Custom Pads.

Place the pads in your layout with the correct spacing.  If your 

component's pin spacing is not 0.1", you may want to change the 

Snap-to-grid spacing in the Options dialog.

Tip:  It is often helpful to move the origin over pin 1 of 

the new part.  Then setting the exact coordinates of a pad 

is easily done by double clicking on it.  If the datasheet 

for the component shows the pin spacing in metric units, 

change the ExpressPCB program to millimeters.  See: 

Units and the Coordinate System.

2. Assign each pad a Pin number.  This must be done if you want to link 

your PCB layout to its schematic.  Assign pin numbers by first 

selecting  and then double clicking on each pad to display its 

Pad Properties dialog box.  In the Pin number field, enter the pin 

number.

3. Draw the component outline for the new part on the silkscreen 

layer.  Draw straight lines by selecting  or circles and arcs using 

.  Be sure to select the silkscreen layer before drawing the 

outline by clicking .  The recommended line width for drawing 

component outlines is 0.012".

4. Group everything together to combine it into a single component as 

follows:  Select all of the objects in your new part by clicking  

and then dragging the mouse to enclose them.  From the Component 

menu, choose the command Group to make PCB component.  Next, 

double click on new component to display the Component properties 

dialog box, then assign the Part ID (i.e. U12).

5. Save your new component to add it to the Custom components list.  Do this by selecting 

the part with the mouse and then choosing Save custom component from the Component 

menu.



FYI:  ExpressPCB stores each custom component in its own file (having a .P 

extension).  You may want to backup your components, or copy them to 

other computers where ExpressPCB is installed.  To locate the directory where 

these files are saved, open the Options dialog box, then select the Misc tab.

Modifying Library Components

In many cases, it is faster to build a new component by starting with a close fit from our library.  

One common example is modifying a library part to use a larger pad size.  This is easily done by 

first inserting the library component into your layout.  Next select it with the mouse and ungroup 

it using the Ungroup PCB component command from the Component menu.  Now select only the 

pads and then double click on one.  In the Pads Properties dialog, change to the new pad size.  

Finally, regroup the component back together as described above to create the new part.  Your 

changes will not affect the original part in the ExpressPCB library.

Making Custom Pads & The Pad Manager

The Pad Manager is used to create new 

pad sizes and to select which pads are 

added to your favorites list.

Display the Pad Manager dialog box by 

selecting Pad Manager from the 

Components menu. 

You may want to add pad sizes that you 

frequently use to your favorite pads list.  

This is done by choosing the Library Pads 

option, selecting the pad size from the 

list box, and then pressing the Add to 

favorites button.

When creating a custom component, you may find that the pad you need is not in our pad 

library.  In this case, press the Create new pad button in the Pad Manager to define a new pad 

size.  Here you can create a new via, through-hole or surface-mount pad.  When designing a pad 

with a through-hole, the pad diameter must be at least 0.017" greater than the diameter of the 

hole.

Displaying Information About a Pad

To determine the diameter and hole size of a pad, whether it is an individual pad or a pad in a 

predefined component, select  from the side toolbar and click on the pad of interest.  A 

dialog box displays the pad information.

Exporting an Image of Your Board

A drawing of your board showing the component placement can be exported in three common 

formats:  as a .BMP, DXF, or .EMF file.

To document the placement of components on your circuit board, use the Export image of 

mechanical drawing command in the File menu.  This command creates a black & white image 

showing the pads and component outlines on the board.  The file can be saved as either a .BMP 

file, or as a scalable .EMF metafile.

A bitmap can also be generated using the Edit menu command Copy silkscreen layer to clipboard.

  The image can then be pasted into a Microsoft Word or other document type.  To make an 



image of your board for the web, we recommend pasting it into a graphics package, then 

converting it to a .GIF file type.

If you work with a mechanical CAD package, you may want to import a drawing of your board 

that includes the exact coordinates of each component pad.  For example, this can be very 

useful when designing an enclosure for your circuit board.  For this purpose, the ExpressPCB 

program can export a board drawing using the common DXF format.  To do this, select the 

Export DXF mechanical drawing command from the File menu. 

Keyboard Shortcuts
ExpressPCB includes many shortcut keys to make laying out circuit boards fast and easy.  In some 

cases, a key will only be active while you are performing a specific operation.

A Select the place text function from the side toolbar.

C Select the place component function from the side toolbar.

D Select the disconnect trace function from the side toolbar.

F Zoom to fit the entire layout.

G Toggle snap-to-grid on and off.

I Select the insert corner function from the side toolbar.

L Toggle between the upper and lower layers.

N Select the highlight net connections function from the side toolbar.

P Select the place pad function from the side toolbar.

R Change the rotation while dragging an item.

S Select the selection function (shown as an arrow) from the side 

toolbar.

T Select the place trace function from the side toolbar.

Z Select the zoom into a selected area function from the side toolbar.

+ Zoom in.

- Zoom out.

Backspace When placing traces, delete the previous trace segment.

Del Delete the selected items from the layout.

Esc Cancel the current operation.

Return When placing traces, end the operation and set the new traces.

Spacebar When placing traces, end the operation and set the new traces.

Ctrl C Copy the selected items into the clipboard.

Ctrl F Search the layout for a component's PartID.

F3 Continue searching the layout for a component's PartID.

Ctrl N Create a new file.

Ctrl O Open an existing file.

Ctrl S Save the current file.

Ctrl V Paste from the clipboard into the layout.

Ctrl X Cut the selected items from the layout into the clipboard.

Ctrl Z Undo the last operation.

Left Scroll main window left.

Right Scroll main window right.

Up Scroll main window up.

Down Scroll main window down.



Ctrl-left Move selected items one pixel left.

Ctrl-right Move selected items one pixel right.

Ctrl-up Move selected items one pixel up.

Ctrl-down Move selected items one pixel down.

Having PC Boards Made
After you design a circuit board with the ExpressPCB layout program, getting the boards made is a 

snap.  To get information on our different manufacturing options, get quotes, and order your 

boards, see:  Having PC Boards Made

How to Get the Most Recent Version of ExpressPCB
The ExpressPCB layout software is periodically revised and improved.  We recommend that you use 

the most recent version of ExpressPCB when designing a new board or submitting a layout for 

manufacturing.  

You can check if you have the most recent program by comparing your current version number (by 

using the About command under the Help menu) with the version number found on the download 

page of our web site www.expresspcb.com.

To receive the most recent version, visit the download page of www.expresspcb.com.  From here 

you can download ExpressPCB at no cost.  Next, run the setup program and install the new version 

in the same directory on your PC as used by the older program.  Any existing layout files or 

components that you have created will automatically be compatible with the new program.

How to Contact Us

Please feel free to contact us if you have questions, comments or suggestions.  We can be reached 

by email at support@expresspcb.com

Our web site is a good source of information about ExpressPCB.  You can also download the latest 

version of our software from our home page.  Please visit www.expresspcb.com
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